nu-plugin-jobcontrol/flake.nix
LordMZTE 852ce5e15c
Some checks failed
/ test (push) Failing after 1m51s
chore: update zig-nuplugin and add nix flake
2024-07-31 09:44:21 +02:00

35 lines
714 B
Nix

{
description = "Nushell plugin for jobcontrol";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs?ref=nixos-unstable";
utils.url = "github:numtide/flake-utils";
};
outputs =
{ self
, nixpkgs
, utils
}: utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; };
deps = pkgs.callPackage ./deps.nix { };
in
{
packages.default = pkgs.stdenv.mkDerivation {
name = "nu-plugin-jobcontrol";
src = ./.;
dontConfigure = true;
nativeBuildInputs = with pkgs; [
zig_0_13.hook
];
postPatch = ''
ln -sf "${deps}" "$ZIG_GLOBAL_CACHE_DIR/p"
'';
};
});
}